Results 1 to 1 of 1

Thread: Type or namespace name "Autodesk" could not be found(Problem at SDK sample compiling)

  1.    #1
    Junior Member
    Join Date
    November 13, 2018
    Posts
    6
    Current Local Time
    03:50 AM

    Exclamation Type or namespace name "Autodesk" could not be found(Problem at SDK sample compiling)

    Hallo, everyone, I am Nan

    I have downloaded REVIT_2019_SDK.msi from https://www.autodesk.com/developer-n...nologies/revit

    After successfully downloading and installing SDK 2019, I tried to compile the samples in the SDK files(See figure 2).

    C:\Revit 2019 SDK\Samples\AllViews\CSz\AllViews.csproj

    The version of my visual studio is 2017. I have installed both .Net framework 4.7 and .Net framework 4.7.1

    The way I installed .Net framework 4.7 and .Net framework 4.7.1 were as follows:

    1: NDP47-DevPack-KB3186612-ENU.exe (see figure 9) for .Net framework 4.7

    2: NDP47-KB3186497-x86-x64-AllOS-ENU.exe (see figure 9) for .Net framework 4.7

    3: NDP471-DevPack-ENU.exe for .Net framework 4.7.1

    4: NDP471-KB4033344-Web.exe for .Net framework 4.7.1, it doesn't work, it says it is because .Net framework 4.7 is already installed




    Ok, after the pre-work, I clicked "build solution ", a lot of errors happened as the main error is (see figure 5 and 6),



    Error CS0246 The type or namespace name 'Autodesk' could not be found (are you missing a using directive or an assembly reference?) ExternalResourceDBServer C:\Revit 2019 SDK\Samples\ExternalResourceServer\ExternalResourc eDBServer\CS\Application.cs 29



    I have tried the .Net framework 4.7 (figure 7) and there is no problem in reference (figure 8)

    I do not know where is the problem. Can anyone help me about this?


    Thank you very much in advance!

    Best wishes

    Nan Zhu
    Attached Thumbnails Attached Thumbnails Type or namespace name "Autodesk" could not be found(Problem at SDK sample compiling)-7.png   Type or namespace name "Autodesk" could not be found(Problem at SDK sample compiling)-8.png   Type or namespace name "Autodesk" could not be found(Problem at SDK sample compiling)-6.png   Type or namespace name "Autodesk" could not be found(Problem at SDK sample compiling)-5.png   Type or namespace name "Autodesk" could not be found(Problem at SDK sample compiling)-4.png  

    Type or namespace name "Autodesk" could not be found(Problem at SDK sample compiling)-3.png   Type or namespace name "Autodesk" could not be found(Problem at SDK sample compiling)-2.png   Type or namespace name "Autodesk" could not be found(Problem at SDK sample compiling)-1.png   Type or namespace name "Autodesk" could not be found(Problem at SDK sample compiling)-10.png   Type or namespace name "Autodesk" could not be found(Problem at SDK sample compiling)-9.png  


Similar Threads

  1. "No parameter found by that name"
    By ryntau in forum Dynamo BIM
    Replies: 3
    Last Post: December 11th, 2018, 09:19 PM
  2. No "Model" type patterns found.
    By anywho in forum Architecture and General Revit Questions
    Replies: 0
    Last Post: October 14th, 2016, 08:28 PM
  3. Error "No circuit errors found" when deleting objects
    By alnjxn in forum Architecture and General Revit Questions
    Replies: 0
    Last Post: August 22nd, 2013, 03:47 PM
  4. Replies: 0
    Last Post: February 14th, 2013, 03:45 AM
  5. RFO Blog: "Can you provide us with a sample file"
    By RFO Blog in forum Blog Feeds
    Replies: 0
    Last Post: April 1st, 2012, 08:15 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •