Results 1 to 3 of 3

Thread: Lookup Table Import - Separator Invalid

  1. #1
    Junior Member EleventhHour's Avatar
    Join Date
    December 20, 2011
    Current Local Time
    09:24 AM

    Not allowed! Not allowed!

    Lookup Table Import - Separator Invalid

    Hi all,

    I've been trying to teach myself about lookup tables and made a first, very very simple .csv lookup table to test the basics. However, I've hit a brick wall with this error - upon importing the lookup table I get the "The separator in the header is invalid" error message.

    The headers both have the very basic "Holesize##length##millimeters" and "HR##length##millimeters" in them (without quote marks) as you can see in the screen shot - is there something obvious that I'm missing?

    After hours of googling & reading the things that I've already tried are:-

    1. Closing both excel and Revit after editing the .csv file / prior to importing
    2. Changing the values from millimeters to millimetres to inches to feet
    3. importing the lookup table .csv file both before and after creating the two required relevant parameters to use the bolts.csv file - although I can't see how this would actually affect the import...
    4. Also tried changing the .csv to a .txt and viewing to make sure that it is using the expected , as the separator and not another symbol - as in second screenshot.

    It seems to be such a simple test but I can't understand what the problem is - can anyone shed any light on this? Thanks.

    Click image for larger version. 

Name:	Import Lookup Table Fail.PNG 
Views:	21 
Size:	99.4 KB 
ID:	34417

    Click image for larger version. 

Name:	Import Lookup Table as text.PNG 
Views:	16 
Size:	8.6 KB 
ID:	34418

  2. #2
    Forum Addict josephpeel's Avatar
    Join Date
    May 3, 2012
    Current Local Time
    10:24 AM

    Not allowed! Not allowed!
    Wierd.. I would suggest you find an existing lookup table in a family that works and use that as the basis (Or at least see what is different)

    Personally I have managed to avoid lookup tables for a long time. I prefer to use formulas.
    If you graph that type of data you can always fit a 'Y=A + Bx' formula to it quite accurately (Use 'fit trendline' and 'show equation' in excel to get A and B)
    Then instead of a lookup table you can use the formula to look up any value of Y from X..
    A and B can be Type Parameters, so you can make types within the same family that use different source data.

    So for example.. Heres data for a bunch of different air grilles and their throw distance for different airflows.
    By graphing this data to get the A and B constants I was able to make one air terminal family that will accurately calculate the throw distance for each type based on the Flow.

    Maybe this seems complicated... but I find it much easier to use than lookup tables.
    I use this method for stuff like pipe fittings too (Outside diameter, flange size etc..) so one pipe fitting can have multiple materials/manufacturers as types.
    Attached Thumbnails Attached Thumbnails Air Grille Type Graphs.JPG  
    Last edited by josephpeel; August 7th, 2018 at 04:10 PM.

  3. #3
    New Member
    Join Date
    August 8, 2016
    Current Local Time
    09:24 AM

    Not allowed! Not allowed!
    try selecting all the blank header cells and pressing delete. you may find you have accidentally put a space in one.

Similar Threads

  1. Lookup table
    By gowthamsamys in forum MEP - General
    Replies: 2
    Last Post: April 16th, 2018, 09:48 PM
  2. Lookup Table Using Number
    By Tim_Ea in forum MEP - General
    Replies: 5
    Last Post: January 31st, 2018, 02:03 AM
  3. Lookup table Yes/no not working
    By Arno in forum Architecture - Family Creation
    Replies: 6
    Last Post: September 28th, 2015, 06:21 PM
  4. Lookup Table: First Column?
    By doni49 in forum Architecture - Family Creation
    Replies: 3
    Last Post: September 27th, 2015, 11:09 PM
  5. Lookup Table issue
    By sabari2504 in forum MEP - General
    Replies: 8
    Last Post: January 15th, 2014, 08:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts