No announcement yet.

Revit Server Not Linking Files on Revit Server

  • Filter
  • Time
  • Show
Clear All
new posts

    Revit Server Not Linking Files on Revit Server

    Hi Guys,

    We are trying to implement Revit Server 2019. I installed all the prerequisites and installed Revit Server 2019 without a problem. Loaded the RSN.ini files on the server and workstations.

    We can open and work, sync to the Revit Server, but we are unable to link models on the Revit Server to other models. From the Model on Revit Server i am able to link a model on my File Server , but i am not able to link another model from the same Revit Server.

    I have been banging my head against the wall for the past 8 hours without any solution. I have tried making new blank models and linking them together with the same effect.

    I have check permissions on the Revit Server "CREATOR_OWNER" , "NETWORK_SERVICE" and "RevitServerService" all has full control over the folder.

    Am i missing something , or does Revit Server just not allow linking files on the same server ?

    I havent specifically tried with 2019 (we dont set up Revit Server, anymore), but you should be able to Link files from the RSN just like any other file.
    Aaron "selfish AND petulant" Maller |P A R A L L A X T E A M | Practice Technology Implementation
    @Web | @Twitter | @LinkedIn | @Email


      Check if port 80 is open between the server and the client, it's possible that something blocks it, firewall or another web service on the server. The Revit Server Rest API uses that port, it's not documented extensively, but required for some commands, e.g. for the etransmit plugin. I'm not sure but it's possible that it's used for linking as well.

      with wget you can check if the rest api is working correctly: replace with the url of your server, 2018 with your revit server version:

      wget -O- --header="User-Name: Adam" --header="User-Machine-Name: AdamPC" --header="Operation-GUID: 11111111-1111-1111-1111-111111111111" "|/contents"
      Wget for Windows

      If you don't get positive answer for this, than there is a problem with the rest api or with port 80. You should get the list of top level models and folders from the revit server formatted as json.


        @infeeee , i have tried your suggestion with the following results :

        Connecting to connected.
        HTTP request sent, awaiting response... 200 OK
        Length: 546 [application/json]
        Saving to: "STDOUT"

        0% [ ] 0 --.-K/s {"Path":"","DriveFreeSpace":-1,"DriveSpace":-1,"Files":[{"IsText":true,"Name":"super.lock","Size":0},{"IsT ext":false,"Name":"ModelLocationTable.db3","Size": 24576},{"IsText":false,"Name":"ModelLocationTable. db3-journal","Size":25136}],"Folders":[{"HasContents":true,"LockContext":null,"LockState" :0,"ModelLocksInProgress":null,"Name":"2017","Size ":461838256},{"HasContents":true,"LockContext":nul l,"LockState":0,"ModelLocksInProgress":null,"Name" :"Test 1","Size":18544682}],"L100%[================================================== ================================================== ================================================== =============================================>] 546 --.-K/s in 0s

        2019-08-29 11:06:21 (27.5 MB/s) - written to stdout [546/546]

        attached is the only error message we receive when trying to attach a file from the RevitServer

        Click image for larger version

Name:	RevitServer.PNG
Views:	1
Size:	20.0 KB
ID:	399534
        Last edited by Munkholm; August 29, 2019, 08:15 AM. Reason: formatting


          So the api is working. I see one strange thing in your response:

          "DriveFreeSpace": -1,
          "DriveSpace": -1,
          On my instance I get this response:

          "DriveFreeSpace": 50446647296,
          "DriveSpace": 64078475264,
          So my first guess is that it's a permission problem as the api service can't read the size of the full disk.

          If you change the drive, it must have the appropriate access rights so the Revit Server can successfully write to it. For best results, set access rights to give full control to the CREATOR OWNER and NETWORK_SERVICE users for the Cache and Projects folders (including sub-folders and files).
          So you need to add rights to the cache folder as well, and check inheritance is enabled. Source:

          Also I see from your wget log that you connect to But I'm sure that it's not the covered text in your screenshot. What if you add to RSN.ini and open it this way not via the domain name? And other ways, does the api answers if you wget to the domain name not the ip? ("It's always DNS")

          Also checkout the logs, it helped me a lot of times, there are some strange permissions you have to add to make it work:


          Related Topics