No announcement yet.

Revit and linked DWG files

  • Filter
  • Time
  • Show
Clear All
new posts

    Revit and linked DWG files

    Hi all,
    came across an annoying problem in Revit wondering if there is a solution.
    I'm working on a coordination model, I need to check that what is being modelled matches my DWG files from a subcontractor.
    So I am creating the same section placements he has, and linking the DWGs in to the view so I can visually verify with the DWG as a .
    I also would like to see the DWG in the 3D view (it would be nice but its not absolutely necessary.)

    I have had to seperate his file so I "wblock" created each section as a seperate file but apart from doing "wblock" I didn't do anything else to the section view that was made in Autocad. I had to do this because 1 dwg file contains about 90 section views, so I had to create each view as a seperate file.

    When I link this in the section view in revit, it only works if I select "active view only" as activated. Therefore I can not see it in the 3D view. The weird thing is that some views work, and some do not. So some of the DWG files will insert visible in all the views, and other times it will insert the dwg with a warning but then the dwg is not visible at all. (even with the cut view option turned off).

    Also for some reason it changes all the dimension entities present in autocad, and the hatching to be on a different "plane" than the rest of the dwg. So when I insert if it does show up in the 3D view, I see 150 metres away my dimensions, and often they are also staggered in that they are not all present in the same "plane". This means when I insert the dwg, it often inserts with a weird "point of insertion" and in addition in the 3D when it actually does work, it quickly pollutes everything else with the weird dimension placements.

    I've tried flatten, this did not really solve my problem. I tried erasing the dimensions, I don't absolutely need them but they would be nice to keep, but erasing them does not solve the visibility issue in some cases the dwg links, but I can not see it at all in my view.

    As troubleshooting points go I have tried (without success)
    In the dwg
    Erase dimensions and hatches

    In the revit file
    Not limiting/clipping the view to the view window

    With success in the revit file
    Making the view depth on my section 500 metres, the DWG is usually visible.
    I just tried refining this a little, and I found I needed a minimum of 80 meters "view depth" on the section property. When I went below this the dwg would disappear, and if I extended again to 80 or greater it would show up the dwg again. This isnt really acceptable for me because I want the section to be quite fine so I can coordinate just the elements in that region where the section is made and not be polluted by everything else behind it

    I'm unable to find out why this wont work on some and does on others, and how to resolve the issue, nor why or how to fix the dimensioning problem. Just to refine that point - it is clearly the view depth that matters for the dwg showing up - but why is it only inserting at 80 meters and not anything smaller?

    Anyone experienced and overcome this before?

    EDIT: I discovered that the DWG is inserting in really random places either deplaced off to the side, or front/back of the insertion points. Even if I reset my insertion base point in the DWG nothing seems to fix this issue.
    Last edited by Karalon10; August 30, 2018, 02:09 PM.

    I've found flatten doesn't always work the way you want in AutoCAD. There have been times where I've had to isolate by category and set the Z to 0 manually
    ​My ID was stolen. Now I'm only called Dav


      Way back in the days when I was still using AutoCAD I had a LISP script that flattened everything in a drawing but that file is long gone.

      What you can try with the dimensions is to explode them (if it is just for checking). They would become plain text and lines, so they would not be referencing anything anymore, but they should keep their value. Flatten the dwg after the explode.

      Did you try Purge and Audit for the dwg's?

      When I import stuff into Revit I make sure the CAD stuff is at the 0,0,0 point in AutoCAD, so I fiscally move everything in the dwg to that point.
      Company Website:
      Revit Ideas: Is this family Mirrored? | Approve warnings | Family Type parameter just those in the family


        Did a little google search and I think this is what I used back then

        Flatten Command or equivalent
        Company Website:
        Revit Ideas: Is this family Mirrored? | Approve warnings | Family Type parameter just those in the family


          While it makes reloading a pain....I found that inserting the DWG into a detail item family does the trick for sections... I usually purge as much as I can though so I don't get too much garbage.
          Michael "MP" Patrick (Deceased - R.I.P)


            Export this rvt to A 3D solides dwg, link it in and start from that situation..
            Last edited by HansLammerts; August 30, 2018, 04:26 PM. Reason: 3D solids



              So, I finally got all this to work after much hair pulling.
              The annoying part is I don't know WHY its doing it, but I can get around it with much manipulation.

              So heres the procedure I need to do to get it to work
              Erase all dimensions in DWG and hatch patterns.
              Flatten, overkill, then purge the DWG.
              Move everything to 0,0,0 and save.

              Open Revit section view, and insert with "visible only in this view" off so it will appear in my 3D view and doesnt seem to matter what I use, so I was just using "manual center" to insert in the section view of revit.
              Now uncheck the "cut to view window" box and see if it just happens to land in the correct "plane" (it doesnt, in general)
              Go to a Plan view with "no limit" set on all the view range options and find the DWG (usually somewhere off to the side of the insertion point but like a LONG way off.
              Grab the DWG (or grab everything and filter the DWG I want) and move it to be over the section location in the plan view and NOW I can align it properly in my section view.

              So I finally got the outcome I wanted, but that is some serious manipulation to do what *should* be a standard insert and maybe align after. Not sure why I need to align it in basically all 3 planes, why do DWGs not just insert as the section view "cut plane" being the insert plane??

              Anyhow, problem solved? Worked around more accurately.


              Related Topics