Announcement

Collapse
No announcement yet.

Structural Framing Family not behaving

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Structural Framing Family not behaving

    Hi all. i have a structural framing beam which i have created using 2 different profiles and then have been sweeped (because i prefer how they behave as to extrusions). the family itself flexes fine using the parameters within the profiles loaded. however, i can not in the world manage to get the centre line of the beam to be correct.

    as i have created a family catalogue the centre line changes on all beams, and the shape handle is 20mm off the bottom? anyone know how they can be restored to the centre?

    when i pull the component end the family stretches fine, however, when i pull the shape handles the beam remain the same size, however, the "start extrusion & End extrusion date in the properties bar change to what the shape handles have been stretched to.

    Please help. thank you
    Attached Files

    #2
    I dont have access to your family, however try this first

    If I understand correctly, the centre line is not adjusting length to the newly set length of the family?

    In your family editor - Click on the "align" button and align to the left and right constraints of your object the ENDPOINT of the centreline symbolic line and lock it to the extents.

    Try this out see if it solves your problem.
    If your centreline is not staying in the centre of your beam if the width changes, add a continuous dimension that goes from top to center to bottom click on the "EQ" text on the dimension string and this should fix that issue.

    Comment

    Loading...
    Working...
    X