No announcement yet.

Synchronization Error Spreading

  • Filter
  • Time
  • Show
Clear All
new posts

    Synchronization Error Spreading

    Hi All,

    I've had a rummage for a solution for this, but haven't found anything useful...

    Large project. Many linked models. Recently updated to R2017 from R2014.

    Since the upgrade a few of the models have done the following:
    - New local file
    - Work as normal
    - Synchronize as normal
    - Attempt to close file = Creates the attached error message 'You have made changes... that have not been synchronized...'

    It throws this error up even if you have literally just synched.

    If you click on either of the options (Synchronize or Close) it seems to just resolve itself and close, but I've noticed this happening on more and more models as I work on them and it's a tad concerning.

    Has anyone else run into this before? If so, how did you resolve it?

    Many thanks :thumbsup:
    Last edited by Grumple; July 6, 2017, 11:13 AM.

    Have you audited the model? Especially with an old, updated project, I'd detach the model, audit it, and save it as a new central model, and work from that new one.

    It was on C4R, but an occasional sync error turned out an element that corrupted the model several days after first issues were noticed. Going back through versions the error was evident much earlier with audit.
    Julie Kidder
    Architect + BIM Director
    Hartman + Majewski Design Group


      Yes all of the models were detached in R2014 and then audited when upgrading them to R2017.

      I've also audited them again to attempt to resolve the issue with no luck...

      How can I attempt to find a corrupt element?



        Have you tried purging the models?
        What if you create a new local file and try playing around in it? Would it still happen? Do you have any corrupted families that you know of?


          I had an issue yesterday with recreating a central model from a local file. Wouldn't save/overwrite the old file in the same directory , even after moving the old central file and kept giving the "incorrect schema" warning. Saved it as a different name and then it worked.
          Might not be your issue but you could try it
          There are no stupid questions, only stupid people


            Thanks for all the input.

            The models were all purged and audited when I did the upgrade - and I've purged and audited the models giving me this error.

            I detached a new copy of the central file and created a new central from it - the problem still persists :banghead:

            I should add at this point that we are using a Nasuni file server, which backs up our data to the cloud - I'm not sure if this could have something to do with the issue (although I never ran into it when on R2014).

            I've escalated to Autodesk, so will update with any fixes/info I receive from them :thumbsup:

            (The renaming idea is interesting - I'd have to then rename back to the original, but it could be worth a shot!)
            Last edited by Grumple; July 7, 2017, 10:05 AM.


              Have no idea if this would cause any corruption issues, but did you leapfrog from version 2014 straight to 2017? I thought it was a generally accepted practice to step through each version when upgrading models due to the proper translation of elements.


                I dont ever step mine through, unless there is a problem DURING an upgrade that im trying to resolve.
                Aaron "selfish AND petulant" Maller |P A R A L L A X T E A M | Practice Technology Implementation
                @Web | @Twitter | @LinkedIn | @Email


                  Originally posted by Grumple
                  ...Synchronize as normal...
                  What is normal? Are you using the Synchronize and Modify Settings (brings up the dialog) or Synchronize Now (no dialog)?

                  SwC (Modify Settings) - allows you to review each of the classes of worksets we can interact with as well as see that borrowed elements exist. Make sure all boxes are checked and complete the Sync. That's the most thorough method.

                  SwC (Now) - No dialog AND it does NOT relinquish User Created worksets. That means you use Synchronize Now and then try to close the file and you'll get a prompt that you need to relinquish. When people don't borrow worksets (not listed as Owner for a workset) it can be easily overlooked when people use Synchronize Now and trip them up later when they do borrow the workset for some reason.

                  If the above is well understood, then my money is on the Nasuni process for syncing your files FWIW, probably a net latency issue.
                  Last edited by Steve_Stafford; July 11, 2017, 06:05 AM.


                    Stepping through is probably a smoother process - but we didn't have any option to do that here.

                    Steve - I always use Synch and modify and leave the options as they are.

                    No news from The Factory yet...


                    Related Topics