Announcement

Collapse
No announcement yet.

Attach top to base will not follow slope of the floor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Attach top to base will not follow slope of the floor

    To my Revit family,

    I have created a column family that represents 'shoring', which is structural supports of the construction of a concrete slab. It is a simple family consisting of 3 shapes, representing 2 columns and a beam. I want the beam to follow the slope of the floor it is supporting and it will not do as I please (as seen in the first attachment). I understand I can create this in the 'structural framing' family and use 3D snaps to get the beam to follow the floor slant but that creates a different issue (as seen in the second attachment). The columns created with the beam also follows the slant of the floor, which is not what I need. It is also not very efficient to use 3D snap when you are trying to trace a 2D CAD. Thank in advance!

    Tristan
    Attached Files

    #2
    Tristan,

    Are you able to post the family? Without be able to view the family it's difficult to figure out what is the cause for your hangups. Did you create the columns and beams separately and then nest them into a host family before inserting it into your project? If so try checking the box in your column family to always vertical, this might solve the issue you are having in the 2nd picture. You could also just use the OOTB columns and beams for this with in the project and then group them together into a shoring group that could be copied around the project as needed. If you go the group route I would suggest using a reference plane to host your beam on that is the bottom side of your concrete slab then attach your columns to the beam prior to creating the group.


    Kyle

    Comment


      #3
      Kyle,

      Thanks for your help. I posted a dropbox link to the family I've created below. I made the beam and columns all in the same column family. If I create the families separate and then host them together which type of family should I do that in?

      The issue in the second attachment I posted above is me creating the columns and beam both in a structural framing family. That is why I could not check the
      'always vertical' box for those columns. I think creating separate families and combining them in one host family is a good idea and I will give it a shot. Thank you.

      Tristan

      https://www.dropbox.com/s/kmvfsartx2...oring.rfa?dl=0

      Comment


        #4
        Tristan,

        I usually start out with a generic model template then switch it to the type of family that I am creating, such as structural framing for beams and structural columns for columns. As for the host family, I think the generic family template would be sufficient enough.

        Kyle

        Comment

        Related Topics

        Collapse

        Working...
        X