Announcement

Collapse
No announcement yet.

Revit Server - Can't Lock from Admin Console

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Revit Server - Can't Lock from Admin Console

    We have run into a problem where we have lost the ability to lock files or folders through the RS Admin Console.

    It's happening to us now and I think we need to get someone to run the Command-Line Utility on the Central Server to try and rebuild the lock database. Unfortunately it's the holidays and the Central Server is two time zones away from me!

    #2
    UPDATE:

    The basic jist of it was something got screwy in the super.lock file that was preventing any additional files from being locked.

    • Someone tried deleting text inside the file itself and that didn’t really help.
    • If they did not leave a blank space at the top of the super.lock file the Admin Console was not accessible
    • Every time we attempted to lock a file or folder the action would be recorded twice in the super.lock file.
    • We could not delete or modify any files or folders using the Admin Console
    • We tried to use the command line lock utility to run “revitserverlock -verify –recreate” and it didn’t do anything but tell us that ‘The database is functional’
    • We renamed and removed the super.lock file and replaced it with one from the server backup from the day before. Only then was the functionality restored in the Admin console

    There we two lines in the super.lock file that we restored from the backup.
    • The first line shows a lock from two weeks prior on a model that no longer exists on the Central Server. Kind of odd that it pops up two weeks later.
    • The second line shows the folder that we were originally trying to lock when this all went south in the first place. It’s like the super.lock file got confused because it was still logging a Lock on a file that no longer existed

    OLD-CENTRAL.rvt|LockReadWrite|12/14/2010 10:26:51 AM|Locked
    FOLDER WE WANT TO LOCK/|LockReadWrite|12/28/2010 6:18:04 AM|Locked


    We went ahead and deleted the first line from the file and everything has been working fine since then. Weird…

    Comment

    Related Topics

    Collapse

    Working...
    X