Donate Now Goal amount for this year: 2500 USD, Received: 2164 USD (87%)

Results 1 to 2 of 2

Thread: Single line work not behaving

  1. #1
    Member evan.dodds's Avatar
    Join Date
    December 29, 2014
    Location
    Calgary, Canada
    Posts
    218
    Current Local Time
    08:32 AM

    Single line work not behaving

    I'm trying to make a multipurpose valve that can switch between being straight and angled in the family. Everything works fine except for one thing: the single line line work does not behave, specifically the part that rotates. I kinda forgot about needing the line work until after I'd made all of the geometry, but even starting in a new family, the rotating line just does not want to behave/wants to break everything.

    I don't know if the reference lines are hindering the symbolic lines from working correctly, but everything works fine if I don't have the symbolic lines in.
    Attached Files Attached Files

  2. #2
    Member evan.dodds's Avatar
    Join Date
    December 29, 2014
    Location
    Calgary, Canada
    Posts
    218
    Current Local Time
    08:32 AM
    Never mind. I figured out that the rotation point was moving for the model line whenever I tried to go from 0° to a bigger angle (but not vice versa), but only when I had drawn the horizontal line segment. In the end I switched my methods so that instead of trying to use an angle parameter to control the rotating part I constrained the end to two reference planes that switch lengths depending if the valve is set to be angled or straight. I guess I should have known to do that from the get go, however it is weird that the reference lines function like expected but the model lines do not.

Similar Threads

  1. Double line and single line pipes based on size?
    By Theophilous in forum MEP - General
    Replies: 2
    Last Post: July 6th, 2018, 05:04 PM
  2. help to display pipe with with only single line
    By trang_chau in forum MEP - Family Creation
    Replies: 2
    Last Post: April 18th, 2016, 02:13 AM
  3. Single line pipework layout
    By fifthtexas in forum MEP - General
    Replies: 14
    Last Post: October 16th, 2015, 03:23 PM
  4. single line display issue
    By RStiles in forum MEP - General
    Replies: 1
    Last Post: July 9th, 2012, 10:54 PM
  5. representation of beams is just single line !!!!!?
    By ahmed_hassan in forum Architecture and General Revit Questions
    Replies: 6
    Last Post: January 1st, 2012, 09:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •