Announcement

Collapse
No announcement yet.

Too thick lines in editor, how to fix?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Too thick lines in editor, how to fix?

    Hi everyone, I'm glad to post today from France my first question!

    When editing a contour for a roof or to create an extrusion in a family, I get very thick pink lines. They are so thick that it's very difficult to adjust the lines, I really don't see what I do. The more I zoom, the bigger they get!!!
    Is there any parameter to adjust in order to get very thin lines while editing?

    Thanks a lot.

    #2
    Hi Eric, welcome to the forum...
    Go to Manage > Additional Settings > Lineweights to check which thickness will be OK, and which number references to it (probably 1 or 2 will be fine)
    Then go to Manage > Additional Settings > Line Styles and look for the line type <Sketch>. Set this to the appropriate value.
    Martijn de Riet
    Professional Revit Consultant | Revit API Developer
    MdR Advies
    Planta1 Revit Online Consulting

    Comment


      #3
      But in the meantime, simply turn of line thickness by entering the keyboard shortcut :

      TL

      -which is only a visual change (like Lineweight in Autocad) - Martijn's explains how to make the change global and permanent :thumbsup:

      Comment


        #4
        I don't like TL since your screen can seriously divert from the plot settings... Which causes some serious confusion and :banghead:
        Martijn de Riet
        Professional Revit Consultant | Revit API Developer
        MdR Advies
        Planta1 Revit Online Consulting

        Comment


          #5
          Originally posted by mdradvies View Post
          I don't like TL since your screen can seriously divert from the plot settings... Which causes some serious confusion and :banghead:
          I know what you mean - and it would be nice never to have to use TL but sometimes it's just nicer to work without thicknesses - and since Eric's in sketch mode print-related disparity isn't really an issue here.

          Comment


            #6
            Originally posted by snowyweston View Post
            I know what you mean - and it would be nice never to have to use TL but sometimes it's just nicer to work without thicknesses - and since Eric's in sketch mode print-related disparity isn't really an issue here.
            True,
            What I meant to say was: I've had myself forget to turn the TL back off so many times I just took the time to do the permanent thing once in my template and have banned the useage of TL all together. But hey, YMMV...
            Martijn de Riet
            Professional Revit Consultant | Revit API Developer
            MdR Advies
            Planta1 Revit Online Consulting

            Comment


              #7
              Fine, but ...

              Thanks guys, I set 1 for the <esquisse> line (ie <sketch>) and it's quite better. But if I make a big zoom, the lines are still very big compared to those of the editor which remain at 1 pixel.

              I find it very fustrating since it's a working line, not a render line, it will never appear in the project, it's just a guide for me to tel Revit where I want the profile, or whatever. Unfortunately, it seems I can't create a 0 size line!

              I wonder how people use this feature in the family editor to create very small details where the <sketch> line is 10 times bigger that the detail and covering it. Compared with what i'm used to in Illustrator or other tools like this, it's very surprising.

              Comment


                #8
                I would add that the plane reference lines, which appear in green, remain 1 px thick at any kind of zoom. One could expect to get the same behavior with <sketch> lines that serve the same purpose. Any idea how to do it ?

                Comment


                  #9
                  I toggle to Thin Lines myself. Sometimes, I design in TL mode. I don't have any issues not seeing the plot settings. And, if I need to see them, its a few keystrokes away.
                  Dan

                  Comment


                    #10
                    Sketch Lines are for some reason View Scale dependant. Or not and everything else is... Either way, it's indeed a bug. I don't think you can do anything about this besides TL.
                    Martijn de Riet
                    Professional Revit Consultant | Revit API Developer
                    MdR Advies
                    Planta1 Revit Online Consulting

                    Comment

                    Related Topics

                    Collapse

                    Working...
                    X