Announcement

Collapse
No announcement yet.

Plumbing Fixture Schedule and Traps

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Plumbing Fixture Schedule and Traps

    I have used all the provided plumbing fixtures and created a Plumbing Fixture Schedule. None of the families have a trap parameter but the fixture schedule has a trap column. I'd like to have the trap size listed on the schedule but can't figure out how to add "Trap" to the families in such a way that the schedule will recognize it.

    I've added "Trap" to the "Plumbing" group and to the "Dimensions" group, but no luck.

    Can anyone help me?

    #2
    Add the "Trap" parameter to the Field. Follow the steps in this thread.
    Keep in mind though, this feature only applies to the project, not to the families themselves. If you want the Trap parameter in the Families, you need to Add this in the Family Editor itself. Whole different ballgame... Is it a Shared Parameter or a Project Parameter?
    Martijn de Riet
    Professional Revit Consultant | Revit API Developer
    MdR Advies
    Planta1 Revit Online Consulting

    Comment


      #3
      I'd like to modify the family's so that the trap size always showed up correctly so I guess it would be "shared parameter" (?) and I tried modifying the family but it never seemed to connect with the "Trap" field in the schedule.

      Comment


        #4
        That can be true...
        Try this:

        1. Open the families concerning.
        2. Add a parameter Trap Size (or something. Just make sure it's another naming then the ones you have in your project already). Make it a Shared Parameter. If you don't use them already, read up about them here.
        3. Re-import the family in the project.
        4. In the project, go to Manage > Project Parameters and add the shared parameter Trap Size to the project.
        5. Open the schedule and add the field Trap Size to the schedule.

        That should do it.
        Martijn de Riet
        Professional Revit Consultant | Revit API Developer
        MdR Advies
        Planta1 Revit Online Consulting

        Comment


          #5
          it worked! many many thanks

          Comment


            #6
            Great... Now about what the problem has been (for future reference):
            Revit does NOT recognize parameters by their name if they're shared parameters. It uses the GUID, which is a really really long and complex code stored in your Shared Parameter file and copied into the project, families that use it, etc. Open your SP-file with a text editor and you will see it. Each GUID is unique and formed with a complex algorithm which allows all users to create their own GUID's without overlapping each other. Delete a Shared Parameter and it's gone forever. If you make a new one and name it exactly the same, it will still be a different parameter because it has a different GUID.

            So the problem has been that you had 2 different types of Trap Size. One made in the project (without a GUID if it was a project parameter or a different one if someone else created that SP) and the new one you created. Those are not the same. And therefor Revit cannot "read" both in one schedule field.
            Martijn de Riet
            Professional Revit Consultant | Revit API Developer
            MdR Advies
            Planta1 Revit Online Consulting

            Comment

            Related Topics

            Collapse

            Working...
            X