Announcement

Collapse
No announcement yet.

Lookup Table - Separator in header is invalid

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lookup Table - Separator in header is invalid

    I have been trying to import a new lookup table for a pipe fitting family, but no matter what I do it gives me the "Separator in Header is Invalid" pop-up. I have dragged myself though countless forums and articles and I can't find anything wrong with my headers. I have even tried working directly from a lookup table that was previously loaded. I have also checked that there are no excess spaces floating around.There must be something I am missing (hopefully simple and obvious). Please help!

    -Ren
    Attached Files

    #2
    Try changing the naming scheme of the parameters that have the _. From what I remember it does not like them too much.

    Might also help to show us your lookup formulas in the family to see if those are having any issues as well.
    Developer at Anguleris BIMsmith Marketplace.
    Previously at Sumex Design for ARCAT.com

    Comment


      #3
      That was part of it. Even though guides said to use underscore it did not like that at all. I also renamed all parameters and replaced A-C naming with 1-3. Glad it was something simple.

      Thank you!

      Comment


        #4
        Hi RenChan, the issue you had was not about parameters inside of Lookup table, but file format itself. As Revit doesn't recognize a file with CSV-UTF-8 format. Kindly change it to CSV(comma delimited) or CSV(MS-DOS). Note that Revit doesn't recognize CSV(Macintosh) format neither. But with CSV(Macintosh), you will get different warning message, like "The lookup table has an invalid column header and can't be imported". Hopefully, this issue is solved.

        Comment


          #5
          Check the .csv file with the Notepad, it's rare but maybe Excel is exportin with (.)dot separator and Revit don't recognize that. If that is the way you can change in Excel options. Also I always save as CSV(Comma delimited) and never had that problem.

          Comment

          Related Topics

          Collapse

          Working...
          X