Announcement

Collapse
No announcement yet.

Family Origin & invisible ligns

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Family Origin & invisible ligns

    I have done wall based electrical outlets.

    I have located the outlet at 0,0 in the family - so when I bring it into revit it sits at 0 on the respective level and I can adjust it's elevation in the elevation property parameter.

    However, sometimes I put the invisible line so it cuts ceiling and/or if at high level on the wall cuts the cut line and displays.

    So sometimes the invisible line is below the origin - which then means that the 'elevation' throws the fitting up by the length of the invisible line.

    Any way to control that I want the 0,0 to be the actual origin that is controlled?

    Thanks


    James
    Attached Files
    Last edited by jameshs; December 31, 2010, 10:59 AM. Reason: spelling!

    #2
    The elevation parameter of the wall-based electrical outlet family takes its value from the elevation of the lowest visible element in relation to the reference level. Therefore, probably you need to draw the invisible line (for example 0,20 m long) below the reference level, and the outlet itself at the reference level. Then, in the project, the elevation parameter will read 0,0 when the outlet is actually at 0,20 m. ; is that what you mean?

    See illustration.
    Attached Files
    Freelance BIM Provider at Autodesk Services Marketplace | Linkedin

    Comment


      #3
      Originally posted by Alfredo Medina View Post
      is that what you mean?
      Alfredo - that is exactly what I mean and it is not the behaviour that I want!

      I am using the invisible lign to allow an electrical fixture to appear on a floor plan when it is set at high level on a wall (eg for a TV) - but this then controls where it sits on the wall, as opposed to the base of the fitting which is where I would like it to be controlled.

      Originally I tried controlling this with a height parameter in the family - but found that I was frequently controlling them with 'elevation' in the properties box. (which then just pushed up the 'origin' controlling my height parameter).

      Is there any way of locking this origin - or supressing the elevation in the properties box - other than making this a floor based family?

      Maybe I am over thinking this one as it is a fairly rare instance - I don't generally want the downward tail as it would poke through to rooms below.

      As a general principle do people put their electrical outlets at the fitting height in the family, or at 0,0 in the family and then elevate in the project?


      James

      Comment


        #4
        whoop whoop - reading another thread the poster said that he put in a reference line and defined it as the origin ..... set me thinking.

        Looked in my project and 'assumed' that 0,0 in the family WOULD control the origin - nope.

        Inserted a simple reference plane at the 0,0 in the family and set that to be the origin, and lo and behold, now that IS the origin and the invisible line below DOES NOT AFFECT the elevation property - it now controls the elevation based on the 'origin' reference ignoring the fact that I have something below.

        Problem solved

        On to the next one!

        Thanks


        James
        Last edited by jameshs; December 31, 2010, 11:20 AM. Reason: spelling!

        Comment


          #5
          Originally posted by jameshs View Post
          whoop whoop - reading another thread the poster said that he put in a reference line and defined it as the origin ..... set me thinking.

          Looked in my project and 'assumed' that 0,0 in the family WOULD control the origin - nope.

          Inserted a simple reference plane at the 0,0 in the family and set that to be the origin, and lo and behold, now that IS the origin and the invisible line below DOES NOT AFFECT the elevation property - it now controls the elevation based on the 'origin' reference ignoring the fact that I have something below.

          Problem solved

          On to the next one!

          Thanks


          James
          James, thanks for sharing your fix. Sometimes people figure out how to resolve a problem that they have and never share it with the group. Sharing is good for all! Happy New Year
          I'm retired, if you don't like it, go around!

          Comment

          Related Topics

          Collapse

          Working...
          X