No announcement yet.

Family not visible in project file

  • Filter
  • Time
  • Show
Clear All
new posts

    Family not visible in project file

    Hi, I know this question has been asked before, but I have tried looking at most

    of the posts on this forum as well as others. But i still cant find any help.

    I made a new family -BEAM (want to use it as an RCC beam). enclosed is the revit family file & jpegs.

    When I first loaded it into the project it showed up. Next I wanted to update it, so deleted it from the project file

    & went back to the family file, made the changes, then tried to reload it, after which It asks you

    "Overwrite the existing version,


    Overwrite the existing version & all its parameters"

    I tried both but I still cant see it in my project file.
    Also tried deleting it from my project browser & changed the view to fine.

    Appreciate any help I can get. Thank you.

    This is what i have tried so far: | I Made a family that doesn't show up in Plan view | BEAM
    Top 10 Reasons You Can?t See an Element in Revit | microsolresources
    RVIT - Revit rants, tips, and junk | It's pronounced \'är-v?t\

    USING : Revit Arch 2012

    Win 7.
    Attached Files

    One of your attached images indicates Beam Systems. Did you use this BEAM in Beam Systems? When you deleted the BEAM family it sounds like you deleted the BEAM family's Type. You should have seen an error message about deleting family instances? If you received the warning message about reloading the family you didn't completely remove the family, just its types. If they were part of a beam system(s) then they are empty, no beams because you deleted them. When you reload the family there aren't any beams to show you. Try placing a new Beam, select your family it should show up in the view. It works for me...


      Sorry you will have to forgive me, I'm new to Revit.
      Yes I may have placed it under Beam systems. But I do know while making the family, under Family Category & Parameters,
      I changed the category from "Generic Model " to "Structural Framing".
      So here is what I have tried now : Changed the category back to "Generic Model ", saved it. Then reloaded it , and IT WORKED.
      Then I deleted it from the "Project Browser " only. Went back into the family, changed the category " to "Structural Framing". saved it & reloaded again IT WORKED again . BRILLIANT . The only thing is it shows up as a 'Structural Framing System" and not the file name "BEAM". (if that is not the right category please correct me, because I want to use as an RCC Beam)

      A big THANK YOU Steve...
      What I have learned I guess : is to delete only from the Project Browser . Is that right ?

      Thanks once again.


      Related Topics