Announcement

Collapse
No announcement yet.

Problem with balauster conection. Please, Help.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem with balauster conection. Please, Help.

    Hello, I'm creating a railing with a round handrail and rectangular profiles as balausters. The balausters have a semicircular cutoff that's intended to lodge the handrail. I've defined the handrail as the top of the balauster and when I give positive values to the top offset, the balauster passes through the handrail as expected. See fig. 2 (offset: +1cm). So I should give negative values to the top offset to try and adjust the posicion of the void and make it match the position of the handrail. Now, the problem is that with a value of zero or less (-2 cm) is the theoric value for a perfect match, the balauster goes directly to the position shown in fig. 1. No transitions. Does anyone know what's happening? (and how to fix it?).
    ThanksProblem with balauster 1.jpgProblem with balauster 2.jpg

    #2
    Can you post the railing family so we can take a look at it? Nice railing, by the way. :thumbsup:
    Dan

    Comment


      #3
      My guess is that you need to give the railing profile an offset from origin so that your offset value in the railing family always stays positive (if you get my drift here)
      Martijn de Riet
      Professional Revit Consultant | Revit API Developer
      MdR Advies
      Planta1 Revit Online Consulting

      Comment

      Related Topics

      Collapse

      Working...
      X