Announcement

Collapse
No announcement yet.

How i can make the family with default project units ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How i can make the family with default project units ?

    Hi everone, How i can make all family template with default project units meter? because i am familiar with metrs more than milimeter.
    Also, the component properties showing the type written 1000 mm * 500mm i need it to be shown in meter only as i am familiar with meter since long long time .
    please help
    Thanks.
    My best Regards

    #2
    Open the family you are working on in the family editor and on the manage tab select "Project Units". Now in that dialog se the "Length" setting to be meters like you want it. Now you can author the family in Meters.

    In the project you can make the same change to make the values for the parameters report in meters rather than MM.
    Jeff Hanson
    Sr. Subject Matter Expert
    Autodesk, Revit - User Experience

    Comment


      #3
      mmm, but i do this every time with every family i open i have to do it. so the default is MM i want to change it to Meter to be default instead. in project i setup my own template to be meter and that is fine but problem here with me is-- family --
      also i want to make the family properties inside project to show its length by meter not by MM for example 1m * 1.5 m not(1000mm * 1500mm).

      Comment


        #4
        Once you make the change save the family file with the change. It will save as an RFA file, but you can simply change the extension to RFT and use this file as a family template. You will have to make this change for each template you wish to convert. There is no way to say that meter is the default. It is saved in the file so each file needs to be changed. Once you convert the template you will never have to set the units again.

        If the project units are meter it does not matter what the family units are. The paramters will report in meters in the project. See the example image. This door family was clearly authored in feet and inches (based on the type name of the door), but when used in a project that is using meters, the parameter values are reporting in meters.
        Attached Files
        Jeff Hanson
        Sr. Subject Matter Expert
        Autodesk, Revit - User Experience

        Comment


          #5
          In that case you need to change the template itself. Find it in your windows browser, double click. Set the PU, save and close. After this it will be set to your default.
          I would recommend that you do a save as to your own library so that you don't have to redo it whenever there's a new update (the updates / new versions tend to write over the existing libraries)
          Martijn de Riet
          Professional Revit Consultant | Revit API Developer
          MdR Advies
          Planta1 Revit Online Consulting

          Comment


            #6
            JeffH, i got your point i thought type 30''*80'' changes with changing project units but it seems that it is based on user pre definition.
            So i will open each file family template and changes it to meter and saved it instead inside RAC 2011 -- metric templates
            @mdradvies i do not know what is PU where its location ?
            thanks JeffH, mdradvies for your reply

            Comment


              #7
              PU = Project Units.
              The Units are NOT based on user predefinitions. There are some OOTB settings (Metric being in mm for instance) but that's the only thing. Anything else is based on your own settings in project / family templates.
              When you open and save, place it somewhere else to avoid them being replaced with the default templates when reinstalling...
              Martijn de Riet
              Professional Revit Consultant | Revit API Developer
              MdR Advies
              Planta1 Revit Online Consulting

              Comment

              Related Topics

              Collapse

              Working...
              X