No announcement yet.

Revit 2018.2 update error

  • Filter
  • Time
  • Show
Clear All
new posts

    Revit 2018.2 update error

    When trying to install the update for Revit 2018.2 I get the Error 1328 Error Applying patch to file C:\Config.Msi\

    I have done a repair and a reinstall (via Apps and Features) and then try to run the update again but without any success.
    I have also tried to change the permissions of the Folder config.msi, empty the temp folder (for the local user name)

    Anyone had this error message?

    We upgraded our Building Suite to a AEC Collection. As the programs as bundled ”different” we had to first uninstall the previous version before installing the AEC collection. Not sure if this have caused the above issue.

    Attached Files

    When you uninstalled did you perform a clean uninstall?

    I switched a seat over a couple weeks ago and had a bunch of issues until i did that...
    Revit for newbies - A starting point for RFO

    BEER: Better, Efficient, Elegant, Repeatable.


      The trouble is, even the instructions they give you for a CLEAN uninstall, arent a clean uninstall. Because they dont show you the specifics of what secondary applications are installed that MIGHT be causing the conflict, that you need to ALSO uninstall to do a REAL clean uninstall. And be warned, if you do a REAL clean uninstall,youve also removed things that are used by 2017 and 2016.

      I went through this with an office recently, and they had IMMENSE trouble with the 2017 and 2018 updates, because of C4R's two applications, PACR (Personal Accelerator) and RCAO (I think this is C4R itself). Removing those applications and THEN running the update worked in some cases, not in others.

      Worth noting, we had other issues complicating things in the office i worked on recently. But, its worth a shot.
      Aaron "selfish AND petulant" Maller |P A R A L L A X T E A M | Practice Technology Implementation
      @Web | @Twitter | @LinkedIn | @Email


        Thank goodness for posting this. I cannot get any of my machines to update. It is not reasonable for us to uninstall Revit 2018 to install Revit 2018.2!


          This is the reason I didn't even LOOK at the 2018 release until this month and probably won't deploy until December at the earliest. The new (half-baked) features are appreciated, but you know what's even better? 12 months of not having to worry about updates and focusing on improving my own content and support. Based on how late into the year they're updating 2018, I'm probably not going to look at 2019 until it's actually the year 2019. [/rant]


            I had no issue installing and getting Revit2018 authenticated with the new license for the AEC Subscription.
            All other software in AEC collection install OK including any updates. It is only Revit2018 that is having an issue.
            Revit2017 installed and upgraded OK.

            I have the exact same issue with installing AEC at home – all programs except Revit 2018 upgrade OK.

            I followed the link with how to do a clean uninstall.



              I just went through the process of un-stalling Revit2018 with all its components again and did follow the guide in above link for a 'clean' uninstall.
              Still the same problem after I tried to update Revit to 2018.2.
              A bit frustrating as we use a 3rd party plugin that has been updated and now only works with Revit2018.2


                quick question, how did you get to the new file for 2018.2? Did you go through your Autodesk account, then to "downloads" for 2018, then to "updates" and get it from there? If not this is how I would recommend getting to the download file...


                  I have tried both installing the update via Autodesk Desktop application and also logging in to our Autodesk web account and then downloaded the Revit2018.2 update file. Yes, I did download the file from the AEC 
                  Both fail.


                    OK. Worth asking but sadly didnt help.

                    I recently had a problem with a plugin that wouldnt work on my laptop but worked on everyone elses no problem. Uninstall, repair, and clean reinstall all did Nothing. What did eventually work was formatting my hard disk. This isn't often a solution for everyone and is I guess last resort. I had the time to do it and had other issues on my laptop also that I knew formatting would resolve.

                    I spoke to the app developers for the plugin that wouldn't work in trying to resolve the issue, and they told me it was likely a problem in my .NET Framework somewhere (no idea how to resolve that but maybe you know more on that than I do) Rather than trying to learn how to fix that, I just reformatted and as I say have had zero problems with installing updates since.

                    Check your Windows updates also, sometimes there is Something that doesnt want to install - I had this issue with mine hence also reason for formatting. I have a feeling it was actually Something missing or bugged in a Windows update that caused the problem.

                    Just did a quick search on "Windows 10 .net Framework vs revit" and this might help

                    I also had a Windows 10 that had been upgraded from Windows 7. When I reinstalled I did a full version of Windows 10 rather than the upgrade.

                    Last edited by Karalon10; October 25, 2017, 12:46 PM.


                    Related Topics