Announcement

Collapse
No announcement yet.

Cad --> revit nightmare

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Cad --> revit nightmare

    Hello all, I cant seem to get Revit to do what I want...

    I have this CAD file, with xrefs and other things in it, that Ive been trying to link to Revit. When I first began linking, It would link correctly except for the xrefs in the CAD file... They wouldn't show up. So i tried binding and exploding the xref (I know, not the right way to do it, but IDK what else to do). After attempting to link the CAD file into Revit after binding and exploding, I receive an error message that says, "A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing." After trying both Save File And Continue, and Continue Without Save, The command processes but nothing shows up, and within my managed links window, the file isn't attached.

    Anyone have any ideas/similar issues/ or any other easier way of bringing CAD into Revit???

    Thanks for the help!

    #2
    Whoah! You've got a lot in there.
    I assume when you say you "tried binding and exploding the xref" you mean you did that in Revit? Or in AutoCAD?
    If you bound it in Revit, yes, that was "not the right way to do it".
    Once you Bound it, the DWG in Revit was no long Linked back to your original

    What you really want to do it Bind the XREFs in AutoCAD, and then Link (never Import) into Revit. (and don't Bind or Explode, either)
    Last edited by DaveP; May 4, 2016, 05:53 PM.
    Dave Plumb
    BWBR Architects; St Paul, MN

    CADsplaining: When a BIM rookie tells you how you should have done something.

    Comment


      #3
      Originally posted by Jessec1117 View Post
      Hello all, I cant seem to get Revit to do what I want...
      Story of my life

      Audit & Purge your CAD file(s). A standard purge probably won't do it - there are a few apps on the Autodesk App Exchange that get a lot deeper. I've been using Radical Purge lately and like it quite a bit. https://apps.autodesk.com/ACD/en/Det...en&os=Win32_64 Also set Proxygraphics to 1 in CAD. It probably isn't the issue but it can help.

      Try linking the CAD into a blank project and see if that works. If it doesn't then you need to dig into the CAD file and figure out what is wrong. A quick fix is to WBlock the whole file out; for whatever reason that seems to fix a lot of oddities. Then try linking into a new blank project.

      Also make sure the CAD file is somewhere close to 0,0,0. If it is far out in the distance (Civil files are bad about that) it can cause errors in Revit.
      Revit for newbies - A starting point for RFO


      chad
      BEER: Better, Efficient, Elegant, Repeatable.

      Comment


        #4
        Try linking with a clean CAD file and you'll see your CAD file is probably the problem. To clean it up -purge and overkill, maybe even copy/paste it to a new file.

        Comment


          #5
          If there is text in your autocad file the has formatting to it this will present problems as well

          Comment


            #6
            Thanks for all of the tips!

            I did bind and explode in AutoCAD, but like what cellophane and Revitaoist said, I started out with a clean CAD file and after copy/pasting and binding/exploding (all in CAD), I was able to correctly Link the CAD file into Revit.

            Such a pain! If only my consultants made the change to Revit!

            Again, Thank you everyone! Its fixed -- well, as fixed as can be....

            Comment

            Related Topics

            Collapse

            Working...
            X