Announcement

Collapse
No announcement yet.

Revit Macro Is Greyed Out (2021)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Revit Macro Is Greyed Out (2021)

    Hello,


    I am using Revit 2021 and I am trying to create macros.


    I followed the guidelines and created Module but when I tried to create a Macro under the module, it is greyed out. And next to module name I get the "Loading the macro failed. Rebuilding the module may resolve this issue." error. At that point I haven't even written single line of code, it is autogenerated by Revit. I tried to rebuilt but it made no sense.


    From macro security settings all macro access is enabled so that shouldn't be an issue, I have also restarted Revit multiple times, restarted my computer but none worked.


    I also deleted the Macros folder under C:\ProgramData\Autodesk\Revit multiple time and restarted Revit but that didn't work either.


    I need your help for this case, I don't know why it allows me to create a module but not allowing me to create macro.


    Your help is highly appreciated.


    Thanks.
    Attached Files

Related Topics

Collapse

Working...
X