Announcement

Collapse
No announcement yet.

Revit OpEd: File Saving Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Revit OpEd: File Saving Issues

    There have been a few threads at AUGI and Revitforum.org alike that discuss an error like this one.


    The folks at Autodesk support have apparently pinned the cause down and are now offering a solution via a post at The Revit Clinic yesterday morning. Here's the text of their post.
    ____ ____ ____ ____ ____ ____ ____

    This post is contributed by Niranjan Kamath who supports Revit on our team in India.

    While working with a workshared file, Revit will report an error whereby the central file is not accessible.This issue occurs only when the clients had a different OS version. We could not recreate the file access issue if the clients were both W7, or both XP for example.

    The reason this happens: Windows 7 client communicates with the server using SMB2, while the Windows XP client uses SMB. This difference in version may cause some file handling issues.

    To resolve this issue disable SMB2 from Server and Win 7 users.

    To disable SMB 2.0 for Windows Vista or Windows Server 2008 systems that are the “client” systems, run the following commands:
    • sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
    • sc config mrxsmb20 start= disabled
    • Note there's an extra " " (space) after the "=" sign.

    To restore SMB 2.0 for Windows Vista or Windows Server 2008 systems that are the “client” systems, run the following commands:
    • sc config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
    • sc config mrxsmb20 start= auto
    • Again, there's an extra " " (space) after the "=" sign.

    In order to disable SMB 2.0 on the server-side computer, follow these steps:

    Warning!
    This document contains instructions for editing the registry. If you make any error while editing the registry, you can potentially cause Windows to fail or be unable to boot, requiring you to reinstall Windows. Edit the registry at your own risk. Always back up the registry before making any changes. If you do not feel comfortable editing the registry, do not attempt these instructions. Instead, seek the help of a trained computer specialist.
    • Run "regedit" on Windows Server 2008 based computer.
    • Expand and locate the sub tree as follows.
    • HKLM\System\CurrentControlSet\Services\LanmanServe r\Parameters
    • Add a new REG_DWORD key with the name of "Smb2" (without quotation mark)
      • Value name: Smb2
      • Value type: REG_DWORD
      • 0 = disabled
      • 1 = enabled
    • Set the value to 0 to disable SMB 2.0, or set it to 1 to re-enable SMB 2.0.
    • Reboot the server.



    Click here to view the entire blog post.

Related Topics

Collapse

Working...
X