Donate Now Goal amount for this year: 2500 USD, Received: 1627 USD (65%)

Results 1 to 4 of 4
Like Tree1Likes
  • 1 Post By elton williams

Thread: Running script creates "Dynamo" and "Dynamo Error" material

  1. #1
    jmk
    jmk is offline
    Forum Addict jmk's Avatar
    Join Date
    December 31, 2012
    Location
    NM, USA
    Posts
    1,420
    Current Local Time
    12:51 AM

    Running script creates "Dynamo" and "Dynamo Error" material

    A coworker and myself are both using (different) scripts in Revit 2019 in Dynamo 2. We just noticed that two materials are being created "Dynamo" and "Dynamo Error" when scripts are run. Any idea what could be causing the materials to be created or how to prevent it? One script is deleting parameters, the other is using material parameters to set other parameters.

  2. #2
    Member CRapai's Avatar
    Join Date
    April 30, 2015
    Location
    Michigan
    Posts
    220
    Current Local Time
    02:51 AM
    Can you post a screen shot of both of your scripts. I don't think your going to get much help here without it becuase it really could be a lot of things, too many too mention.

  3. #3
    jmk
    jmk is offline
    Forum Addict jmk's Avatar
    Join Date
    December 31, 2012
    Location
    NM, USA
    Posts
    1,420
    Current Local Time
    12:51 AM
    This is the smaller of the two scripts, which I created quickly today to work on our project template. The other is far to complex to try to troubleshoot.

    It does use a node by steam nodes, but the other script doesn't, so I don't think that is the issue.
    Attached Files Attached Files

  4. #4
    Forum Addict elton williams's Avatar
    Join Date
    December 7, 2010
    Location
    Gold Coast
    Posts
    2,609
    Current Local Time
    04:51 PM
    Quote Originally Posted by jmk View Post
    A coworker and myself are both using (different) scripts in Revit 2019 in Dynamo 2. We just noticed that two materials are being created "Dynamo" and "Dynamo Error" when scripts are run. Any idea what could be causing the materials to be created or how to prevent it? One script is deleting parameters, the other is using material parameters to set other parameters.
    Happens to me all the time. You can drop a few extra nodes in yoir scripts to delete the dynamo created materials but I don't really worry about them now as they don't seem to have any asset elements either

    Or you can just purge-unused them.
    amoursol likes this.

Similar Threads

  1. Replies: 4
    Last Post: August 2nd, 2017, 02:30 PM
  2. Replies: 0
    Last Post: April 5th, 2017, 08:45 AM
  3. Replies: 1
    Last Post: August 30th, 2016, 04:00 PM
  4. Replies: 8
    Last Post: March 21st, 2016, 11:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •