Donate Now Goal amount for this year: 3000 USD, Received: 1207 USD (40%)

Results 1 to 6 of 6
Like Tree1Likes
  • 1 Post By cellophane

Thread: Setting Revit Parameter by "Phase Created"

  1. #1
    New Member
    Join Date
    August 23, 2012
    Posts
    3
    Current Local Time
    10:47 AM

    Setting Revit Parameter by "Phase Created"

    I am very new to Dynamo. This is my first kick at the can and I am trying to use dynamo to eliminate some user inputs in our structural projects. I have a custom parameter "Tag Prefix" attached to multiple categories, including structural framing, and our structural framing tag references the "Tag Prefix""Type Name" to give us a tag that reads (N)W12x26. What I am trying to accomplish is to set the "Tag Prefix" parameter based on the "Phase Created". I have attached my first try. Obviously I have something wrong since it only sets (E) to all structural framing. Thanks in advance for your help.
    Attached Thumbnails Attached Thumbnails Setting Revit Parameter by "Phase Created"-phase-based-tag-prefix.png   Setting Revit Parameter by "Phase Created"-phase-based-tag-prefix.png  
    Last edited by bteskey; January 26th, 2018 at 05:11 PM.

  2. #2
    Moderator cellophane's Avatar
    Join Date
    August 9, 2011
    Location
    Louisville, KY
    Posts
    6,104
    Current Local Time
    12:47 PM
    Your IF statement is currently only pushing the value E through to the families. Your best option is probably to filter your columns by phase and then push the values that way. See attached for one option on filtering the list.
    Attached Thumbnails Attached Thumbnails Setting Revit Parameter by "Phase Created"-filterlist.png  
    amoursol likes this.

  3. #3
    New Member
    Join Date
    August 23, 2012
    Posts
    3
    Current Local Time
    10:47 AM
    Thanks for your help! I am still not sure how exactly to set the parameter value. I am still getting an error in the final step on the attached image.
    Attached Thumbnails Attached Thumbnails Setting Revit Parameter by "Phase Created"-rev1.png  

  4. #4
    Junior Member TomekTomek's Avatar
    Join Date
    May 20, 2016
    Posts
    18
    Current Local Time
    04:47 PM
    You may only change parameters that are listed in Elements.Parameters node. Even this not always works.



    Another thing to remember is that Revit considers walls, beams etc. as separate objects from their tags.

    Consider a workflow where you change a parameter in your structural framing element and tags just display this information.
    Attached Thumbnails Attached Thumbnails Setting Revit Parameter by "Phase Created"-bez%A0tytu-u.png  
    Last edited by TomekTomek; January 27th, 2018 at 06:33 PM.

  5. #5
    Junior Member
    Join Date
    July 1, 2015
    Posts
    18
    Current Local Time
    12:47 PM
    Could you elaborate further? This sounds like something I would be interested in as well.

    Thank you!

  6. #6
    Moderator cellophane's Avatar
    Join Date
    August 9, 2011
    Location
    Louisville, KY
    Posts
    6,104
    Current Local Time
    12:47 PM
    Quote Originally Posted by bteskey View Post
    Thanks for your help! I am still not sure how exactly to set the parameter value. I am still getting an error in the final step on the attached image.
    Instead of stringing the Element.Name nodes, go directly from the List.FilterByBoolMask into the SetParameter nodes. The SetParameter node is expecting an element, not a string. If you mouse over the warning dialog it should say something about how it is expecting an array rather than a string (I don't have it open at the moment to double check..)

Similar Threads

  1. Replies: 4
    Last Post: June 7th, 2016, 01:32 PM
  2. Changing Phase from "New Construction" to "Existing"
    By joshea191 in forum Architecture and General Revit Questions
    Replies: 3
    Last Post: May 13th, 2014, 12:23 PM
  3. Error Message: "None of the created elements are visible in Floor Plan"
    By efficiencydesign in forum Architecture and General Revit Questions
    Replies: 2
    Last Post: March 8th, 2014, 08:05 AM
  4. Shared parameter for "phase" in sheet titleblock?
    By boriskam1991 in forum Architecture and General Revit Questions
    Replies: 1
    Last Post: December 20th, 2012, 10:28 PM
  5. Created sloped wall using "in place mass" and want to add window
    By nsoufiani in forum Architecture and General Revit Questions
    Replies: 3
    Last Post: December 7th, 2012, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •