As you are probably aware, when moving from Dynamo 0.9 to 0.9.1 you lose backward compatibility... in other words, you can't open 0.9.1 files in 0.9 or earlier.
Before taking that step up to 0.9.1 and beyond, you may wish to apply a filename suffix to all of your DYN files, so you are reminded of this issue when you open a DYN. I have a single folder with subfolders containing most of my DYN files, and I added the suffix (082) to all of them at once with this method:

Install Advanced Renamer.

Add the Directory that holds all your dyn files:

Then add a suffix to the filename:

Now, you basically have an inplace backup of files. When you open one of these dyns in 0.9.1 or newer, just remember that you should Save As in Dynamo, and then newly saved file will not be open-able in 0.9 or earlier.

At some point in the future you can then remove or upgrade all of these 'older' Dynamo files.


Click here to view the entire blog post.