Donate Now Goal amount for this year: 2500 USD, Received: 1869 USD (75%)

Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19
Like Tree1Likes

Thread: Incorrect Schema

  1. #11
    New Member
    Join Date
    October 18, 2012
    Posts
    1
    Current Local Time
    10:41 AM
    Quote Originally Posted by NY808 View Post
    I am having the same problems. It is impossible for me to save anything in Revit 13.

    I'll even open a new revit project- architctural, structural, or MEB template. Then, to test, I save that file. The file will save, Revit crashes, and and "incorrect schema" error pops up. When I try to open the saved file, it says incorrect schema.

    I uninstalled every autodesk product, then reinstalled Revit 13. The same error still occurs.

    What is going on???
    Did you find a solution to this problem? This just started happening to me today.

  2. #12
    New Member
    Join Date
    October 13, 2012
    Posts
    2
    Current Local Time
    10:41 AM

    Unzip downloaded package

    Thanks for your reply.

    I didn't unzip the downloaded package before continuing with setup.exe; Re-installed using the unzipped folder, and everything works perfectly.

  3. #13
    Member
    Join Date
    February 3, 2011
    Location
    London, Ontario
    Posts
    397
    Current Local Time
    10:41 AM
    Quote Originally Posted by cellophane View Post
    I just tried to open a model I was working on earlier today and got a message stating that the file has an incorrect schema.

    First - what is a schema?
    Second - what makes it incorrect?
    Third - fixable?
    Hi Chad,

    Did you get this message while trying to save your file, or did the message just pop up?

    I just had a user report the same issue when trying to save. She is working on a workshare file although I understand you were not. We ended up doing a save as, made a new local, was able to then STC successfully and then we created a new local. All seems to be ok now.
    N_Hollenbeck likes this.

  4. #14
    Moderator cellophane's Avatar
    Join Date
    August 9, 2011
    Location
    Louisville, KY
    Posts
    6,164
    Current Local Time
    10:41 AM
    Quote Originally Posted by Jj Mac View Post
    Hi Chad,

    Did you get this message while trying to save your file, or did the message just pop up?

    I just had a user report the same issue when trying to save. She is working on a workshare file although I understand you were not. We ended up doing a save as, made a new local, was able to then STC successfully and then we created a new local. All seems to be ok now.
    I believe it was during opening but I honestly don't remember.

  5. #15
    Moderator LeanneZ's Avatar
    Join Date
    December 8, 2010
    Location
    Charlotte, NC
    Posts
    764
    Current Local Time
    10:41 AM
    Quote Originally Posted by Jj Mac View Post
    Hi Chad,

    Did you get this message while trying to save your file, or did the message just pop up?

    I just had a user report the same issue when trying to save. She is working on a workshare file although I understand you were not. We ended up doing a save as, made a new local, was able to then STC successfully and then we created a new local. All seems to be ok now.
    thanks JJMac... I just had this message happen to me while trying to save a file. I hadn't done much of anything in the file so I just closed without saving and relinquished elements... I was able to open a new local file (which I do everytime I open a WS project) without issue.

  6. #16
    New Member
    Join Date
    March 20, 2013
    Posts
    1
    Current Local Time
    08:41 AM
    New guy here... (new to forum not to revit)

    I just had this happen to user yesterday, the trick I used was similar to JjMac but different... I did a save as to the local file, didnt change the name only compacted the file then was able to save to central, all works well, seems the compacting eradicated the error.

  7. #17
    Member aperte's Avatar
    Join Date
    August 9, 2011
    Posts
    67
    Current Local Time
    07:41 AM
    for documentation purposes, adding to this thread.

    Team user received the 'incorrect schema' warning about 10-15 minutes after a successful STC. A local save was successful, but all attempts to STC triggered the warning and subsequent cancel of STC. Creation of a new Local was successful, but we are still unawares of what caused/triggered the warning/#failboat.

  8. #18
    Forum Addict elton williams's Avatar
    Join Date
    December 7, 2010
    Location
    Gold Coast
    Posts
    2,626
    Current Local Time
    12:41 AM
    I've just had this issue pop up again on a project that isn't workshared. Went through the process of saving a recovery file etc etc but no, not even that made any difference, still the 'incorrect schema' warning and Revit would die.

    Ok, I'll open a backup file...hmm they're all saying 'incorrect schema'...wtf. Hovering over the recovery file in the open file dialogue, the 'detach from central' check box is available..WTF??? This project was NEVER workshared!

    Restarted Revit again and now ALL the project files open fine...WTF!

    Seems possible the problems can be on the software side too, not just a miss-saved file?

    BTW all of this was done using the open file dialogue within Revit, not by clicking on a file in windows explorer.

  9. #19
    Junior Member
    Join Date
    August 13, 2014
    Posts
    10
    Current Local Time
    04:41 PM
    The Best Solution I found for this was when it Happened to one user today, and I tried to save as, compact, open the file again, SWC, and again revived the same ugly message: Revit error: file.rvt contains an incorrect schema.

    the best solution i found was to close Revit, then from the run command type in: %temp% then i deleted as much files as i could, some files wouldnt delete because they are being used some other softwares but thats okay since the are not files for revit use (its close already) + move the backup folder files so there is no wrong information to be retrieved as well, then when i opened the local file, i could SWC again

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Curtain Wall Door reporting incorrect level
    By rkitect in forum Architecture and General Revit Questions
    Replies: 3
    Last Post: August 3rd, 2018, 05:11 PM
  2. Pipe Size Incorrect
    By dzatto in forum MEP - General
    Replies: 4
    Last Post: July 16th, 2012, 03:58 PM
  3. Replies: 0
    Last Post: July 13th, 2011, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •