Donate Now Goal amount for this year: 3000 USD, Received: 1207 USD (40%)

Page 1 of 2 12 LastLast
Results 1 to 10 of 14
Like Tree1Likes

Thread: Loading an early-version revit family.

  1.    #1
    Member
    Join Date
    June 11, 2012
    Location
    Portsmouth
    Posts
    55
    Current Local Time
    01:49 PM

    Loading an early-version revit family.

    I have prepared a family using Revit 2014 which I want to put on my web-site for download.

    My question is: Will users of later versions of Revit be able to load my family?

    Thanks. Daniel
    Attached Files Attached Files

  2.    #2
    Senior Member Andres Franco's Avatar
    Join Date
    June 21, 2012
    Location
    Tours, France
    Posts
    937
    Current Local Time
    02:49 PM
    Quote Originally Posted by cve60069 View Post
    I have prepared a family using Revit 2014 which I want to put on my web-site for download.

    My question is: Will users of later versions of Revit be able to load my family?

    Thanks. Daniel
    Hi, Yes!! they will be able to download and use it in projects which are made in further versions of Revit, they'll just need to update and that's all! the only problem is if you are trying to going backwards with Revit! further files don't work in previous versions

    I'm using Revit 2019.2

    Attached Thumbnails Attached Thumbnails Loading an early-version revit family.-family.jpg  
    Last edited by Andres Franco; April 2nd, 2019 at 09:43 AM.

  3.    #3
    Member
    Join Date
    June 11, 2012
    Location
    Portsmouth
    Posts
    55
    Current Local Time
    01:49 PM
    Thanks. Very much appreciated.

  4.    #4
    Senior Member Andres Franco's Avatar
    Join Date
    June 21, 2012
    Location
    Tours, France
    Posts
    937
    Current Local Time
    02:49 PM
    you're welcome, we are here to help and be helped!!

  5.    #5
    Mr. Revit OpEd
    Join Date
    December 14, 2010
    Posts
    2,861
    Current Local Time
    05:49 AM
    You should test loading it into the other versions too. Revit 2018 and 2019 complain about constraint issues that don't generate complaints in older versions.
    tidalwave1 likes this.

  6.    #6
    The Moderator with No Imagination MPwuzhere's Avatar
    Join Date
    December 14, 2010
    Location
    Coeur d Alene, ID
    Posts
    4,697
    Current Local Time
    05:49 AM
    Breaks when I modify anything....using 2019. The array loses it's restraint and the Span 2 EQ should constrain to the center reference plane (pinned) vs the one it is restrained to now.

  7.    #7
    Member
    Join Date
    June 11, 2012
    Location
    Portsmouth
    Posts
    55
    Current Local Time
    01:49 PM
    MP

    Thanks for the feed-back. I attach a modified family with the EQ pinned and I have unjoined all elements.

    I appreciate your comments.
    Attached Files Attached Files

  8.    #8
    The Moderator with No Imagination MPwuzhere's Avatar
    Join Date
    December 14, 2010
    Location
    Coeur d Alene, ID
    Posts
    4,697
    Current Local Time
    05:49 AM
    Quote Originally Posted by cve60069 View Post
    MP

    Thanks for the feed-back. I attach a modified family with the EQ pinned and I have unjoined all elements.

    I appreciate your comments.
    Span 2 is still EQ to that rogue reference plane so it doesn't stay centered. Did you try to align and lock that to the pinned one by chance?

    A couple of the side bearings break when you change your array, so they are not constrained properly. I suggest using a profile sweep within your family vs a separate nested family for that. Make the profile a type and you can associate the profile dimensions with the parameters in your family.

  9.    #9
    Member
    Join Date
    June 11, 2012
    Location
    Portsmouth
    Posts
    55
    Current Local Time
    01:49 PM
    MP

    I took your advice and changed the structural edge to a sweep. Works in my Revit; doe's it in yours.

    Many thanks
    Attached Files Attached Files

  10.    #10
    The Moderator with No Imagination MPwuzhere's Avatar
    Join Date
    December 14, 2010
    Location
    Coeur d Alene, ID
    Posts
    4,697
    Current Local Time
    05:49 AM
    Don't know why you couldn't just used one sweep instead of 4 sweeps and 4 corner objects.... Must have a good reason.

    I got a constraint error when changing the lenses, probably from that center reference plane for Span 2. Also the side bearings break when you change the X Lenses to 5.

    You might be better off with an overall dimension in the family itself for X and Y... Such as XLength=(Span 1+Structural Edge 3 + Structural Edge 4) and YLength=(Span 2+Structural Edge 1+Structural Edge 2)

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 0
    Last Post: September 6th, 2018, 01:15 AM
  2. Loading of Diffuser family
    By zacoolm in forum MEP - General
    Replies: 1
    Last Post: April 22nd, 2013, 07:54 PM
  3. Replies: 0
    Last Post: August 16th, 2012, 03:15 AM
  4. Loading Family (Doors)
    By amahp in forum Architecture and General Revit Questions
    Replies: 9
    Last Post: April 2nd, 2012, 10:17 PM
  5. loading family
    By Tom Dolle in forum Architecture and General Revit Questions
    Replies: 5
    Last Post: March 23rd, 2012, 04:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •