Results 1 to 5 of 5

Thread: Model Keeps Regenerating Roof with Every Command

  1. #1
    New Member
    Join Date
    January 31, 2017
    Posts
    4
    Current Local Time
    04:36 AM

    Model Keeps Regenerating Roof with Every Command

    Starting yesterday, every time I move a wall, copy a window or change door types I get an issue that causes the model to freeze and then in the bottom left is says "Save the active project back to the Central Model: Regenerating: Constructing Roof" (also see attached image). This is takes about 15 minutes to resolve every time I try to do something. Does anyone have any idea why my model is grinding to a halt all the sudden??

    A few things that might help:
    • File size is 74mb
    • I have synced the model many many times before and after the error
    • The error occurs on any view
    • I have tried 4 different computers in our office and its the same
    Attached Thumbnails Attached Thumbnails Model Keeps Regenerating Roof with Every Command-capture.png  

  2. #2
    Forum Co-Founder Twiceroadsfool's Avatar
    Join Date
    December 7, 2010
    Location
    Dallas, TX
    Posts
    9,675
    Current Local Time
    03:36 AM
    1. Are there any Warnings associated with that roof if you select it?
    2. How amny walls attached to it?
    3. How many line segments is the sketch?
    4. Shape Edited? If so, how many points?

  3. #3
    New Member
    Join Date
    January 31, 2017
    Posts
    4
    Current Local Time
    04:36 AM
    Quote Originally Posted by Twiceroadsfool View Post
    1. Are there any Warnings associated with that roof if you select it?
    2. How amny walls attached to it?
    3. How many line segments is the sketch?
    4. Shape Edited? If so, how many points?
    1. There are no warnings when I select or edit the roof
    2. There are about 50-60 walls connected to the roof
    3. There are 30 line segments in the sketch
    4. Im not 100% sure what you mean by shape edited but I have not done any editing of the roof outside of assigning slopes to segments

  4. #4
    Member mjajansen's Avatar
    Join Date
    December 26, 2011
    Posts
    147
    Current Local Time
    10:36 AM
    You can try to turn off ''enable analytical model'' if you don't use that.
    You can turn it off for all you roofs, floors and walls to speed up editing those things.
    Last edited by mjajansen; March 6th, 2017 at 09:10 AM.

  5.    #5
    Moderator cellophane's Avatar
    Join Date
    August 9, 2011
    Location
    Louisville, KY
    Posts
    6,002
    Current Local Time
    04:36 AM
    I have a project currently that is having this issue. From what I can tell, there is something off in the roof sketch (or walls if using pick-walls) by a very tiny amount and the software is having issues dealing with it. I did a little trouble shooting a while back that cleared up some of it, although as of this morning it is back (I combined two roof sketches to get a convoluted join made )

    The roof in my case was done with pick walls and an offset so most of my adjustments were to the walls in the model the first time I cleaned things up:

    1. Create (duplicate) a new dimension style that is set to Decimal (I used feet, inches would work too), and set the tolerance as tight as Revit will let you: 0.0000000001
    2. Open a plan view (or make a new one), and turn off everything that isn't your walls. If you can filter out walls that aren't used for roof placement, turn those off too (i.e. turn off brick veneer) unless they are how you are locating your roof.
    3. Start dimensioning. I ran 2 strings - one in my normal dimension style: 6'-4 7/8" and one in the decimal string: 6.406250000000
    4. You will probably start finding small inconsistencies in your dimensions over the course of the building. Instead of 6'-4 7/8" (6.406250000000) you will find strings that are off by a stupid amount: 6'-4 7/8" (6.406249999999)
    5. Fix these. You will need to move the walls by a small amount - 1/2" is plenty.
    6. Now move the wall back by activating the dimensions and typing in the correct value.


    It is super tedious and takes forever, but the end result means your roof actually works.

    All that said - I was able to at least break the connection between the roof and the walls by copying the roof into a new project and pasting it back. Depending on where you are in the process that might not be very viable though..

Similar Threads

  1. Really Slow Model, Lots of regenerating
    By Damenk in forum Structure - General Questions
    Replies: 10
    Last Post: March 23rd, 2016, 09:26 AM
  2. How to model stair stringers using the "Beam" command.
    By keithf in forum Structure - General Questions
    Replies: 3
    Last Post: March 12th, 2015, 12:45 PM
  3. Roof Model Challenge
    By jcoe in forum Architecture and General Revit Questions
    Replies: 2
    Last Post: May 24th, 2014, 02:14 AM
  4. How do I model this roof ?
    By raincatsdogs in forum Architecture - Conceptual Massing and Adaptive Components
    Replies: 2
    Last Post: November 20th, 2012, 10:02 PM
  5. How would you model this roof ?
    By Ye Zaw Lin in forum Architecture - Conceptual Massing and Adaptive Components
    Replies: 11
    Last Post: November 8th, 2012, 11:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •