Donate Now Goal amount for this year: 2500 USD, Received: 2164 USD (87%)

Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Magical Line Style

  1. #1
    Junior Member Aretap's Avatar
    Join Date
    April 11, 2011
    Location
    Nebraska
    Posts
    27
    Current Local Time
    12:52 PM

    Post Magical Line Style

    Ok so I have a detail component that is purged of EVERYTHING. All Object Styles, All Families (except Fill Pattern....) All Groups, EVERYTHING! IT is blank! When I load it into a project however it brings with it Line Styles???


    Has anyone seen this?? What is going on?

    I have attached the Empty Detail component so that you can do it yourselves. Just open it and load it into a test project and you will see the MAGICALLY Appearing Line Style(s)?????
    Attached Thumbnails Attached Thumbnails Magical Line Style-2011-06-09_0926.png  
    Attached Files Attached Files
    Last edited by Aretap; June 9th, 2011 at 03:46 PM.

  2. #2
    Administrator Munkholm's Avatar
    Join Date
    December 7, 2010
    Location
    Kingdom of Denmark
    Posts
    4,223
    Current Local Time
    07:52 PM
    You canīt delete it from within the family, because Lines Styles is unavailable... But you CAN:

    • Load it into a project.
    • Delete the Line Style in the project.
    • (Close the family if itīs open)
    • Open the family by choosing to "Edit" it from the project.


    The family that you are now having open, do not carry this Line Style (Which is probably a old "left over")

  3. #3
    Junior Member Aretap's Avatar
    Join Date
    April 11, 2011
    Location
    Nebraska
    Posts
    27
    Current Local Time
    12:52 PM
    Perfect Thanks!

    Why in the world does the RFA house or remember the Line Style of the RVT that it was housed?? Families don't have Line Styles? That seems ridiculous to me!?!?!

  4. #4
    Member Jrobker's Avatar
    Join Date
    December 9, 2010
    Location
    Salt Lake
    Posts
    178
    Current Local Time
    10:52 AM
    families don't have lines styles because they're created within the object styles of the family.
    Than you can place solids or model/symbolic lines on that object style which essentially is a subcategory line style.
    But you're right, not very intuitive and kinda ridiculous.

  5. #5
    Moderator
    "Mark Twain"
    mdradvies's Avatar
    Join Date
    December 16, 2010
    Location
    Boxtel, Netherlands
    Posts
    4,551
    Current Local Time
    05:52 PM
    Quote Originally Posted by Munkholm View Post
    You canīt delete it from within the family, because Lines Styles is unavailable... But you CAN:

    • Load it into a project.
    • Delete the Line Style in the project.
    • (Close the family if itīs open)
    • Open the family by choosing to "Edit" it from the project.


    The family that you are now having open, do not carry this Line Style (Which is probably a old "left over")
    Yes, but what happens when you reload it in the project? I know there are several Linetypes and Materials that are put right back by Revit when you ropen the file in the Family Editor and/or re-import in the project. Hardcoded content it is. If this happens, stop worrying, can't be removed...

  6. #6
    Administrator Munkholm's Avatar
    Join Date
    December 7, 2010
    Location
    Kingdom of Denmark
    Posts
    4,223
    Current Local Time
    07:52 PM
    Quote Originally Posted by mdradvies View Post
    Yes, but what happens when you reload it in the project? I know there are several Linetypes and Materials that are put right back by Revit when you ropen the file in the Family Editor and/or re-import in the project. Hardcoded content it is. If this happens, stop worrying, can't be removed...
    I did load the newly opened family into a new blank project... How else could I have verified that the Line Style was gone? (Line Style not being accessible from the Family Editor) LOL.

    Actually, itīs "only" the hardcoded build-in Object/Line Styles that gets put right back in, and not any custom Styles

  7. #7
    Forum Co-Founder Twiceroadsfool's Avatar
    Join Date
    December 7, 2010
    Location
    Dallas, TX
    Posts
    10,341
    Current Local Time
    12:52 PM
    Quote Originally Posted by mdradvies View Post
    Yes, but what happens when you reload it in the project? I know there are several Linetypes and Materials that are put right back by Revit when you ropen the file in the Family Editor and/or re-import in the project. Hardcoded content it is. If this happens, stop worrying, can't be removed...
    Those Materials/Fill Patterns/Linestyles only REappear in the family if the family is opened with Edit Family, from an RVT. If you open the family directly they do NOT show up in the project again. Also, if they are deleted and the family is reloaded, they do NOT show up in the project.

    I painstakingly went through all 2200 of our families this year removing junk default materials, fill patterns, and linestyles, etc.

    EDIT: Not counting the linestyles it wont let you delete. Youre obviously stuck with those. Although... However unstable, there are tricks to deleting the protected content. It involves hitting the delete key too rapidly, making it get ahead of itself with the *are you sure* dialogue box. For instance, even though it normally doesnt let you, you can get rid of all the fill patterns, instead of all but the last one, etc. Same with materials... Never tried with Linestyles, but ill bet the same mishap exists.

  8. #8
    Junior Member Aretap's Avatar
    Join Date
    April 11, 2011
    Location
    Nebraska
    Posts
    27
    Current Local Time
    12:52 PM
    Quote Originally Posted by Twiceroadsfool View Post
    Those Materials/Fill Patterns/Linestyles only REappear in the family if the family is opened with Edit Family, from an RVT. If you open the family directly they do NOT show up in the project again. Also, if they are deleted and the family is reloaded, they do NOT show up in the project.
    Even if I opened the family directly they did still show up... Did not matter, I still had to load it into and RVT and then remove the Line Styles (these are custom Line Styles not System Line Styles) and then save the family off from within the RVT...

    Considering the fact that Families to not have Line Styles I think it is odd that they can technically remember the Line Styles from the Project they were originally saved out from!

    Oh well I have a work around even if it is a HUGE pain in the Butt!

    Thanks Guys!

  9. #9
    Forum Co-Founder Twiceroadsfool's Avatar
    Join Date
    December 7, 2010
    Location
    Dallas, TX
    Posts
    10,341
    Current Local Time
    12:52 PM
    Ours dont. If i go File Open > Open the family from the library, the *hardcoded* stuff doesnt reappear...

  10. #10
    Moderator
    "Mark Twain"
    mdradvies's Avatar
    Join Date
    December 16, 2010
    Location
    Boxtel, Netherlands
    Posts
    4,551
    Current Local Time
    05:52 PM
    Quote Originally Posted by Twiceroadsfool View Post
    Those Materials/Fill Patterns/Linestyles only REappear in the family if the family is opened with Edit Family, from an RVT. If you open the family directly they do NOT show up in the project again. Also, if they are deleted and the family is reloaded, they do NOT show up in the project.

    I painstakingly went through all 2200 of our families this year removing junk default materials, fill patterns, and linestyles, etc.

    EDIT: Not counting the linestyles it wont let you delete. Youre obviously stuck with those. Although... However unstable, there are tricks to deleting the protected content. It involves hitting the delete key too rapidly, making it get ahead of itself with the *are you sure* dialogue box. For instance, even though it normally doesnt let you, you can get rid of all the fill patterns, instead of all but the last one, etc. Same with materials... Never tried with Linestyles, but ill bet the same mishap exists.
    Wow, never realised that! Good to know, but I'm afraid this means that it isn't really helpful to delete all. It really doesn't bother me enough to be forced to go "I want to Edit this family, o wait: find it in the Explorer, then Open instead of clicking > Edit Family...

Page 1 of 2 12 LastLast

Similar Threads

  1. Forum Style / Layout
    By Dave Jones in forum Forum Suggestions and Feedback
    Replies: 67
    Last Post: February 11th, 2011, 03:19 PM
  2. Magical Shared Parameters
    By Alex Cunningham in forum Architecture - Family Creation
    Replies: 2
    Last Post: January 28th, 2011, 03:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •