Donate Now Goal amount for this year: 3000 USD, Received: 1207 USD (40%)

Results 1 to 4 of 4
Like Tree2Likes
  • 1 Post By Robin Deurloo
  • 1 Post By TomekTomek

Thread: Symbol with shared parameters in titleblock

  1. #1
    Senior Member
    Join Date
    December 16, 2010
    Posts
    849
    Current Local Time
    12:05 AM

    Symbol with shared parameters in titleblock

    Making a title block where I thought I would be really clever and nest in a symbol.
    Pretty easy to manage I thought, however I am using shared parameters in the symbol to input text.

    In my project file I have imported the shared parameters that were created in the titleblock and placed them on "sheets" as instance properties.
    The parameters show up on my sheet, so I can type them in the sheets but they do not then show this text in my titleblock symbol...

    Symbol contains text and labels - the labels point to the shared parameters.
    The symbol is inserted in the titleblock family
    I added a yes/no parameter to make the symbol appear or not as an instance property.

    The yes/no parameter works.
    The parameters are present in my project (ie have been shared to project)
    When I fill in text in my sheet properties the labels do not report the values.

    What am I missing?
    Last edited by Karalon10; December 22nd, 2017 at 08:28 AM.

  2. #2
    Moderator Robin Deurloo's Avatar
    Join Date
    July 7, 2011
    Location
    Rotterdam, Holland
    Posts
    1,169
    Current Local Time
    04:05 PM
    I have a label in my sheet that displays Custom Scale (when I have views of different scales on 1 sheet) I toggle a yes/no parameter and it switches visibility between the standard scale and the custom scale. The parameter is text.

    It is a Label on the title block referring to a shared parameter 'Custom Scale'
    And in my project it is used as a Project Parameter for all sheets.

    When I fill in the parameter in my sheet (as instance Parameter) it does show up in my titleblock.

    I think that is what you are looking for, right?

    This is how I got it to work, maybe that helps you along.
    cganiere likes this.

  3. #3
    Senior Member
    Join Date
    December 16, 2010
    Posts
    849
    Current Local Time
    12:05 AM
    well yes, ok I didnt explain completely

    I created a symbol containing shared parameters.
    I inserted the symbol (and the shared parameters file) into the title block family.
    I inserted the titleblock family (containing the symbol) into the project
    I loaded the shared parameter text file into the project
    I created project parameters assigned to sheets (using the parameters originally created in the symbol family)

    These parameters show on my sheet to be filled in as text (as intended)
    but they do not show up on my titleblock.

  4. #4
    Junior Member TomekTomek's Avatar
    Join Date
    May 20, 2016
    Posts
    18
    Current Local Time
    02:05 PM
    Is your symbol 'Shared' as in here?
    The fall proof method is to add parameters first to your sheet in family editor and then connect them to your symbol.
    cganiere likes this.

Similar Threads

  1. titleblock parameters via dynamo
    By ncurcio in forum Dynamo BIM
    Replies: 1
    Last Post: July 24th, 2017, 02:54 PM
  2. Titleblock -lost parameters
    By MARIA1993 in forum Architecture and General Revit Questions
    Replies: 3
    Last Post: February 16th, 2017, 07:41 PM
  3. How do I add additional instance parameters to a titleblock?
    By TuShay in forum Structure - General Questions
    Replies: 0
    Last Post: December 15th, 2016, 10:10 PM
  4. Replies: 0
    Last Post: July 31st, 2015, 05:15 AM
  5. Import shared parameters into an existing shared parameters file
    By Ree in forum Architecture and General Revit Questions
    Replies: 8
    Last Post: January 14th, 2013, 10:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •