Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Title block

  1. #1
    Member
    Join Date
    August 30, 2011
    Location
    brookline , ma
    Posts
    287
    Current Local Time
    12:05 PM

    Title block

    how to use rvt family titleblock made from imported autocad import, looks good in family made with text and lables. how to get it into project hopefully as default. it comes into the project looking like it wants to be exploded (can't be worked on and does not look exactly what i made in the family), can't it just replace the default rvt title block some how? can't anything be easy? do you have to bring the custom title block seperately for each different template sheet

  2. #2
    Forum Co-Founder Twiceroadsfool's Avatar
    Join Date
    December 7, 2010
    Location
    Dallas, TX
    Posts
    4,671
    Current Local Time
    06:05 AM
    You make an RFA, not an RVT. File > New > Annotation Symbol > Titleblock.

    You shouldnt use an Imported DWG, you should make it out of Lines, Text, and Labels in Revit. You dont ever want to explode DWG.

    Loading in your new RFA and replacing all of your old ones works perfectly, and you can use 1 RFA for every sheet in the project, if you build it in native Revit.

    The more you try to bring stuff from AutoCAD, the more trouble you are going to have.

  3. #3
    Member
    Join Date
    August 30, 2011
    Location
    brookline , ma
    Posts
    287
    Current Local Time
    12:05 PM
    what i did was to import autocad title block, trace over it in revit and letter over it in revit text and labels. Than i tried to import the the new titleblock revit family into the project.
    it came in. but i cant highlight individual parts(the whole thing highlights at once. i can't make changes and i can't find text or labels to work with in the project.
    from what you said you have to bring th custom in one at a time for each sheet. but apparently that is the least of my worries.... Thank you alot for trying to help me..

  4. #4
    Forum Co-Founder Twiceroadsfool's Avatar
    Join Date
    December 7, 2010
    Location
    Dallas, TX
    Posts
    4,671
    Current Local Time
    06:05 AM
    No, thats not what i said.

    So you made a family? Or a project file, for the titleblock? It sounds like you made a family, thats good. Now you have Lines, and Labels, and the DWG file is gone, correct? Okay.

    So you load it in the project, and you can place it on each sheet. If you have made the labels correctly, when you select the titleblock (yes, it highlights all at once), the labels should turn blue. If they arent turning blue, then you either need to: Use Project Information Parameters, or Drawing Sheet Parameters (which are in the titleblocks), or Shared Parameters. If you used Shared, you need to also load them in to the project, under Project Parameters (Manage Ribbon).

    What exactly are you trying to "change" on different sheets? The Size and linework of the titleblock? If its that, you need parametrics in the family. Its not going to let you "just grab lines" and toss them this way and that, and thats a good thing. If its line visibility: Make a parameter in the family.

    Once you have it PLACED on one sheet, hit Copy > paste Aligned > Selected views > Select all your sheets at once, and its done.

  5. #5
    Member
    Join Date
    August 30, 2011
    Location
    brookline , ma
    Posts
    287
    Current Local Time
    12:05 PM

    title block

    maybe these 2 files will help explain my difficulty.
    Attached Files Attached Files

  6. #6
    Moderator
    "Mark Twain"
    mdradvies's Avatar
    Join Date
    December 16, 2010
    Location
    Boxtel, Netherlands
    Posts
    4,553
    Current Local Time
    11:05 AM
    The problem is you hardly used any labels... (Project info: all text. So that's static and not possible to edit in your project)
    Or used them wrong: Sheet name: You used 3 rows (and 1 more for drawing nr). This will give you 3 rows of the same text.

    I redid some of your titleblock to give you an idea.
    The point is: this is the Autocad way of setting up your Title block. Where the "parameter" and value have nothing to do with each other. Revit is different.
    EVERY part of info on your titleblock that you want to change in your project needs to be a SEPARATE parameter. Why? Cause the data is stored within the project. So that when you add a sheet (even if it's a different size or even when it's a different family), Revit will "read" the info you stored for that parameter and reuse it.
    Iow, if you create a second Titleblock family with a different size, and reuse Project Name, Revit will "know" this and fill it in for you. If you add another sheet, Revit will look at the last sheet number and automatically number this one correctly. If you, by accident, use a Sheet Name already in use, it will warn you. And so on...
    Attached Files Attached Files

  7. #7
    The Moderator with No Imagination MPwuzhere's Avatar
    Join Date
    December 14, 2010
    Location
    Coeur d Alene, ID
    Posts
    2,594
    Current Local Time
    04:05 AM
    For one thing your "Sheet Name" can only be one label, not multiple...

    The titleblock on the 224 model shows as Title.0007....so its a backup file...loading in youro Title blockcopy the information starts to update....and you will see why you cannot have multiple sheet name labels...

    For Sheet Number your trying to use Sheet Name....

    When you select a label you will see all the parameters you can utilize to the left....in the middle you see a green arrow and a red arrow....move the parameter you want to use using the green arrow and remove the one you don't want with the red. Just modifying the sample value does not do this, its just a placeholder value.

    Oh....and instead of just adding another titleblock to a sheet view....select the existing titleblock and change it to a different one. That way if you want to copy and paste something that will be a titleblock view only it won't jump around.
    Last edited by MPwuzhere; September 18th, 2011 at 09:07 PM. Reason: Another observation

  8. #8
    Member
    Join Date
    August 30, 2011
    Location
    brookline , ma
    Posts
    287
    Current Local Time
    12:05 PM
    first i made a family, then loaded it in the project, when i highlighted it every thing turned blue. no i don't want to change any lines, just text and labels,can you do that? i don't know how. By the way i got rid of autocad title block with visibility graphics vv. i don,t see how to delete Thanks for the last tip.copy/paste ect. select all sheets at once...... do you just delete all of the default revit sheets? maybe if i make it visible i can tab it and delete, but it seems to go blue with the revit.

  9. #9
    Moderator
    "Mark Twain"
    mdradvies's Avatar
    Join Date
    December 16, 2010
    Location
    Boxtel, Netherlands
    Posts
    4,553
    Current Local Time
    11:05 AM
    Look at the differences between your titleblock and mine.
    btw: when you have your labels instead of text, you can fill them in one of two ways:

    1. Select the entire title block and fill the parameters through the properties.
    2. Select the desired text field directly. You need to place your cursor above the label and then click.

  10. #10
    Member
    Join Date
    January 18, 2011
    Posts
    65
    Current Local Time
    04:35 PM
    Hi

    Is there a way to customise the labels. .
    It seems that we can edit only labels in the title block.
    But i would like to have some specific parameters which is not listed in the labels.

    can u suggest how to do it.


    Thanks

Page 1 of 3 123 LastLast

Similar Threads

  1. Replies: 0
    Last Post: August 17th, 2011, 10:20 AM
  2. Title Block Text Hidden
    By WVReviter in forum Architecture - Family Creation
    Replies: 2
    Last Post: May 24th, 2011, 06:08 PM
  3. Revision block and title block
    By soboyle in forum Architecture and General Revit Questions
    Replies: 1
    Last Post: April 25th, 2011, 09:22 AM
  4. [Solution Available] - Title Block Instance Bases Labels
    By Alex Cunningham in forum 2011 Archive
    Replies: 7
    Last Post: March 14th, 2011, 09:29 PM
  5. Title Block Question
    By JCM in forum Architecture and General Revit Questions
    Replies: 19
    Last Post: March 11th, 2011, 04:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •